Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 09, 2024 - 04:00 PST
Scheduled
We will be running scheduled maintenance on our servers that should last up to 20 minutes. We will set a 1 hour window as the downtime will occur between 4:00AM - 5:00AM PT. All API's and the Shipsurance Management Center website will be unavailable during this window.
Please take precautions if you are trying to insure packages or file claims during this window.
Posted Sep 24, 2024 - 15:12 PDT
This scheduled maintenance affected: API Services and Websites (Management Center Website, Shipsurance.com).